Update von Natty auf Oneiric

Zunächst schlug das normale
sudo do-reease-upgrade
fehl, weil auf dem 64-bit-System schon die Kompatibilitäts-Bibliothek für 32-bit-Anwendungen installiert worden war..
Meldung:
An unresolvable problem occurred while calculating the upgrade:
E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Das lag am Paket ia32-libs
Hab es entsprechend https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/873883 deinstalliert:
sudo apt-get remove ia32-libs
und dabei in Kauf genommen, dass skype, wine, und flash mit deinstalliert werden.

Danach mit
sudo apt-get install skype:i386
Skype wieder installiert, dabei wird ia32-libs wieder installiert und libcupsys2 deinstalliert.
Dieses libcupsys2 scheint aber irgendwie bedeutungslos zu sein.
Dann wine genauso, da lief alles glatt, weil der Weg von skype schon geebnet war.
sudo apt-get install wine
Für Flash kam ein Prompt von KDE, hab es dann auch darüber installiert.

Bei Evolution gab es noch Migrationsprobleme, hab dann hin und her spamassassin und evolution de- und re-installiert,
und manuell nach dem Migrieren das restliche ~/.evolution gelöscht. Scheint jetzt alles zu laufen.

Advertisements

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s