Twinkle compiliert, heldenhaft!

Habe es zuerst mit diesem Paket versucht,
sudo dpkg -i /tmp/twinkle_1.4.2-2.1_amd64.deb
# aber:
twinkle hängt ab von libboost-regex1.46.1 (>= 1.46.1-1); aber: Paket libboost-regex1.46.1 ist nicht installiert.
twinkle hängt ab von libccgnu2-1.7-0; aber: Paket libccgnu2-1.7-0 ist nicht installiert.
twinkle hängt ab von libccrtp1-1.8-0; aber: Paket libccrtp1-1.8-0 ist nicht installiert.
twinkle hängt ab von libqt3-mt (>= 3:3.3.8-b); aber: Paket libqt3-mt ist nicht installiert.
twinkle hängt ab von libzrtpcpp-1.4-0; aber: Paket libzrtpcpp-1.4-0 ist nicht installiert.

Also von der Twinle-Seite die Quellen heruntergeladen:
twinkle-1.4.2.tar.gz

dann

tar xzf Downloads/twinkle-1.4.2.tar.gz
cd twinkle-1.4.2/


apt-get install libboost-regex1.50.0 # beim Versuch, das Paket twinkle_1.4.2-2.1_amd64.deb doch noch zum Installieren zu bringen.
# Erstmal Compiler installiert:
sudo apt-get install libccgnu2-1.8-0
# Dann immer wieder ./configure aufgerufen, und
# dann Schritt für Schritt die fehlenden Pakete installiert,
# wenn es nicht per apt-get ging, habe ich die Pakete direkt,
# meist von Lucid über Launchpad heruntergeladen:

sudo apt-get install libcommoncpp2-dev
sudo apt-get install libccrtp-dev
sudo apt-get install libzrtpcpp2
sudo apt-get install libzrtpcpp-dev
sudo apt-get install gpp
sudo apt-get install g++ # Endlich! -- Das scheint der beste Compiler zu sein

sudo dpkg -i /tmp/libccgnu2-1.7-0_1.7.3-1.1_amd64.deb # wird für das folgende Paket gebraucht
sudo dpkg -i /tmp/libccrtp1-1.8-0_1.8.0-1.2build1_amd64.deb
sudo dpkg -i /tmp/libccrtp-dev_1.8.0-1.2build1_amd64.deb
sudo apt-get install libxml2-dev

sudo apt-get install libxrandr-dev
sudo apt-get install libsm-dev
sudo apt-get install libxmu-dev
sudo apt-get install libxcursor-dev
sudo apt-get install libxinerama-dev
sudo apt-get install libxi-dev

sudo apt-get install libjpeg62-dev
sudo dpkg -i /tmp/libqt3-mt-dev_3.3.8-b-6ubuntu2_amd64.deb # immernoch massenweise unerfüllte Abhängigkeiten
sudo apt-get -f install # das hat dann viele Bibliotheken installiert:

#Install: libx11-xcb-dev:amd64 (1.5.0-1), libexpat1-dev:amd64 (2.1.0-1ubuntu1), libxdamage-dev:amd64 (1.1.3-2build2), comerr-dev:amd64 (2.1-1.42.5-1ubuntu2), libgl1-mesa-dev:amd64 (9.0-0ubuntu1), libxxf86vm-dev:amd64 (1.1.2-1), libkrb5-dev:amd64 (1.10.1+dfsg-2), libfontconfig1-dev:amd64 (2.10.1-0ubuntu3), x11proto-gl-dev:amd64 (1.4.16-1), libgssrpc4:amd64 (1.10.1+dfsg-2), mesa-common-dev:amd64 (9.0-0ubuntu1), libglu1-mesa-dev:amd64 (9.0.0-0ubuntu1), libdrm-dev:amd64 (2.4.39-0ubuntu1), x11proto-xf86vidmode-dev:amd64 (2.3.1-2), libxcb-glx0-dev:amd64 (1.8.1-1ubuntu1), x11proto-damage-dev:amd64 (1.2.1-2), libcups2-dev:amd64 (1.6.1-0ubuntu11.3), libfreetype6-dev:amd64 (2.4.10-0ubuntu1), libkadm5clnt-mit8:amd64 (1.10.1+dfsg-2), libaudio-dev:amd64 (1.9.3-5), libkadm5srv-mit8:amd64 (1.10.1+dfsg-2), libxft-dev:amd64 (2.3.1-1), libkdb5-6:amd64 (1.10.1+dfsg-2), krb5-multidev:amd64 (1.10.1+dfsg-2), x11proto-dri2-dev:amd64 (2.8-1)
#Aber das gewollte Paket wieder entfernt:
#Remove: libqt3-mt-dev:amd64 (3.3.8-b-6ubuntu2)
sudo apt-get install qt3-dev-tools
sudo dpkg -i /tmp/qt3-dev-tools_3.3.8-b-6ubuntu2_amd64.deb
sudo dpkg -i /tmp/libqt3-headers_3.3.8-b-6ubuntu2_amd64.deb
sudo apt-get -V install libjpeg62-dev # hier zweites Mal zum Rausschmeißen eine alten Version, einmal reicht eigentlich
sudo dpkg -i /tmp/libmng1_1.0.9-1ubuntu1_amd64.deb # Das ist jetzt recht blindes rumprobieren...
sudo apt-get -fV install
#Install: libjpeg-turbo8-dev:amd64 (1.2.1-0ubuntu2, automatic), libjpeg-dev:amd64 (8c-2ubuntu7, automatic), libjpeg8-dev:amd64 (8c-2ubuntu7, automatic)
#Upgrade: libmng-dev:amd64 (1.0.9-1ubuntu1, 1.0.10-3build1)
#Remove: libqt3-mt-dev:amd64 (3.3.8-b-6ubuntu2), libjpeg62-dev:amd64 (6b1-2ubuntu2)

sudo apt-get -V install libsndfile1-dev
sudo apt-get -V install libvorbis-dev
sudo apt-get -V install libogg-dev
sudo apt-get -V install libsndfile1-dev
sudo apt-get -V install libmagic-dev
sudo apt-get -V install libcrypto++-dev
sudo apt-get -V install libssl-dev
sudo apt-get -V install libucommon-dev
sudo apt-get -V install libreadline-dev
sudo apt-get -V install libboost-dev
sudo apt-get -V install libboost-regex-dev
sudo apt-get -V install libncurses5-dev

sudo dpkg -i /tmp/libqt3-mt_3.3.8-b-6ubuntu2_amd64.deb
sudo dpkg -i --force-depends /tmp/libqt3-mt-dev_3.3.8-b-6ubuntu2_amd64.deb
# Es muss ein Bug ausgebessert werden, entsprechend http://qt-project.org/forums/viewthread/16992
# diese Zeile hinzugefügt: #include
sudo vi /usr/share/qt3/include/qmap.h

./configure --without-zrtp # Hab zwar "zrtp" versucht zu installieren, es gab aber beim Compilieren Probleme
make
msudo make install
# Es entstand ein lauffähiges Twinkle --YEAH!! -- Aber ohne ALSA-SUpport, also für mich nutzlos.

Advertisements

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s