Normalen Update-Prozess unter wine für wiso 2013 ermöglicht

Problem

Wenn man den auf „Nach Updates suchen“ klickt, kommen einige kleine Fenster
etwa „verbinde mit Buhl-Server“, aber dann bricht der Prozess mit diesem wine-Fehler ab:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NotImplementedException: The method or operation is not implemented.
at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
at Buhl.Bdmsc.FormBdmsc.WaitAndExecute_OnWaitWorkerEvent(Object sender, WaitEventParams e)
at Buhl.Bdmsc.Classes.AsyncWaitAndExecute.DoEvent(Object sender, WaitEventType eventType)
at Buhl.Bdmsc.Classes.AsyncWaitAndExecute.bw_RunWorkerCompleted(Object sender, RunWorkerCompletedEventArgs e)
at System.ComponentModel.BackgroundWorker.OnRunWorkerCompleted(RunWorkerCompletedEventArgs e)
at System.ComponentModel.BackgroundWorker.AsyncOperationCompleted(Object arg)

************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
[...]

Lösung
Inspiriert von
http://forum.linux-club.de/viewtopic.php?f=90&t=111203 und
http://www.winehq.org/pipermail/wine-bugs/2013-April/351258.html:
Adobe Reader 9.5 und Internet Explorer 8 installiert, ich weiß nicht,
was von beiden es gebrtacht hat.

wine AdbeRdr950_de_DE.exe
winetricks -q ie8

Advertisements

ssl-Pakete repariert

Problem
kaputte Paketverwaltung auf Kubuntu 12.04 Precise nach Heartbleed
libssl1.0.0 sollte unterschidliche Versionen bekommen:
„1.0.1-4ubuntu5.11“ „1.0.1-4ubuntu5.12“ „1.0.1-4ubuntu5.13“

Lösung
Entsprechend https://answers.launchpad.net/ubuntu/+source/apt/+question/231941

sudo dpkg --purge --force-depends libssl1.0.0:i386
sudo dpkg --purge --force-depends libssl1.0.0:amd64
sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get remove python2.7-dev python-dev libssl-dev libsnmp-dev
sudo apt-get dist-upgrade

Danach funktionierte das Paketsystem wieder wie geschmiert.

rake-Installation vertrug sich nicht mit rbenv

Problem
rake steht nicht in den shims, wahrscheinlich weil es unter
/usr/local/bin/rake
installiert ist. In der Datei steht aber ein expliier Verweis auf die Ruby-Version,
dadurch funktioniert das Umschalten mit rbenv nicht.

Lösung
einfach /usr/local/bin/rake editiert und den expliziten Bezug auf die Ruby-Version rausgenommen,
wie hier beschrieben:

http://lobotuerto.com/blog/2010/04/09
/problemas-con-rake-con-ruby-1-8-y-ruby-1-9-instalados/