qdbus-Problem bei Upgrade auf Trusty behoben

Problem

Nach Upgrade zu Kubuntu 14.04 kam nach dem Anmelden nur:
"Could not start d-bus. Can you call qdbus?"

Versucht, qdbus aufzurufen mit:
"/usr/lib/x86_64-linux-gnu/qt4/bin/qdbus " not found

Lösung

https://www.kubuntuforums.net/archive/index.php/t-65005.html

Zunächst:
sudo apt-get install qdbus-qt5

Das reichte aber noch nicht, KDE wollte weiterhin Qt4 Vewrwenden.
Dann einfach in /usr/bin/startkde QT_SELECT gesetzt:


# 2014-09-12, Sven: ad-hoc way to make kde use qt5 instead of qt4
export QT_SELECT=qt5
# first tried to remove quotes as suggested on https://bugs.launchpad.net/ubuntu/+source/kde-workspace/+bug/1304805
#alias qdbus=QT_SELECT=qt4 qdbus
# orig:
#alias qdbus="QT_SELECT=qt4 qdbus"

Advertisements

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s