ssl-Pakete repariert

Problem
kaputte Paketverwaltung auf Kubuntu 12.04 Precise nach Heartbleed
libssl1.0.0 sollte unterschidliche Versionen bekommen:
„1.0.1-4ubuntu5.11“ „1.0.1-4ubuntu5.12“ „1.0.1-4ubuntu5.13“

Lösung
Entsprechend https://answers.launchpad.net/ubuntu/+source/apt/+question/231941

sudo dpkg --purge --force-depends libssl1.0.0:i386
sudo dpkg --purge --force-depends libssl1.0.0:amd64
sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get remove python2.7-dev python-dev libssl-dev libsnmp-dev
sudo apt-get dist-upgrade

Danach funktionierte das Paketsystem wieder wie geschmiert.

Canon MP280 Multi-Drucker/Scanner eingerichtet

Entsprechend https://answers.launchpad.net/ubuntu/+source/cups/+question/175575

Drucker:

tar xzvf cnijfilter-mp280series-3.40-1-deb.tar.gz
cd cnijfilter-mp280series-3.40-1-deb/packages/

sudo dpkg -i cnijfilter-common_3.40-1_amd64.deb
sudo dpkg -i cnijfilter-mp280series_3.40-1_amd64.deb

Dann über die Gui-Systemeinstellungen den Drucker hinzugefügt.

Scanner:

tar xvf MP280series_scanner_driver.tar
tar xzvf scangearmp-mp280series-1.60-1-deb.tar.gz
cd scangearmp-mp280series-1.60-1-deb/
./install.sh

Ausgabe:
Command executed = sudo dpkg -iG ./packages/scangearmp-common_1.60-1_amd64.deb
[sudo] password for sunito:
Vormals abgewähltes Paket scangearmp-common wird gewählt.
(Lese Datenbank ... 378866 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacken von scangearmp-common (aus .../scangearmp-common_1.60-1_amd64.deb) ...
scangearmp-common (1.60-1) wird eingerichtet ...
Trigger für libc-bin werden verarbeitet ...
ldconfig deferred processing now taking place
Command executed = sudo dpkg -iG ./packages/scangearmp-mp280series_1.60-1_amd64.deb
Vormals abgewähltes Paket scangearmp-mp280series wird gewählt.
(Lese Datenbank ... 378911 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacken von scangearmp-mp280series (aus .../scangearmp-mp280series_1.60-1_amd64.deb) ...
scangearmp-mp280series (1.60-1) wird eingerichtet ...
Trigger für libc-bin werden verarbeitet ...
ldconfig deferred processing now taking place
Installation has been completed.

Der Aufruf erfolgt dann mit scangearmp
Die ganzen sane-Tools funktionieren nämlich leider noch nicht.
(#ToDo# Sane für ScanGear)

KDE-Updates eingeschaltet

Problem:

Nervige Bugs von KMail

Lösung:

Update auf KDE 4.7.3, entsprechend http://www.kubuntu.org/news/kde-sc-473

# Das KDE-Update-Repository hinzufügen:
sudo add-apt-repository ppa:kubuntu-ppa/ppa

# Jetzt der eigentliche Upgrade-Prozess:
sudo apt-get update
sudo apt-get upgrade
# (hat bei meiner 6MBit-Leitung 20 Minutne gedauert.)

Das hat natürlich zur Folge, dass ab jetzt alle monatlichen KDE-Bugfix-Releases eingespielt werden.
Aber das kann eigentlich nur gut sein.

KMail: Nachrichten bleiben in der Outbox

Symptom

Wenn man eine neue erstellte Nachricht absenden wollte, ist sie einfach nur in
den Postausgang gewandert, aber nicht verschickt worden. Auch wenn man „Postausgang versenden“
geklickt hatte. Es gab keine Fehlermeldung im Mail-Fenster.

Wenn man kmail von der Konsole startete, konnte man in solch einem Moment die Warnung
kdepimlibs (mailtransport) MailTransport::SendQueuedAction::itemAccepted: Item doesn't have DispatchModeAttribute
sehen.

Lösung

Entsprechend http://forums.gentoo.org/viewtopic-t-881625-start-0.html

Zunächst die Akonadi-Konsole installiert
sudo apt-get install akonadiconsole

Dann diese mit akonadiconsole gestartet, und dort den „Mail Dispatch Agent“ entfernt und wieder einen neuen „Mail Dispatch Agent“ hinzugefügt.
Danach benahm sich KMail wider normal.

libdvdcss2 installiert (zum DVD-Abspielen)

Symptom

Kaffeine sagt:
Lesefehler von:
Error reading from DVD

Lösung

Entsprechend diesr Anleitung:
http://ubuntuguide.org/wiki/Ubuntu:Oneiric#libdvdcss

Also:
sudo wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list
sudo apt-get update
sudo apt-get --yes --allow-unauthenticated install medibuntu-keyring
sudo apt-get update
sudo apt-get install libdvdcss2

Dann funktionierte das Abspielen.

Zusatz

Außerdem Windows-Codecs noch gleich mitinstalliert:
sudo apt-get install w32codecs
sudo apt-get install w64codecs

Und auch:
sudo apt-get install vlc

Versuche, K4Dirstat zu installieren

Beim vorletzten Ubuntu-Release (natty) ist ja kdirstat (leider) aus dem Repository geflogen.
Dort hatte ich es ja direkt aus den git-Quellen compiliert.

Diesmal hab is versucht, es aus PPA-Paketen zu installieren,
Also…

Ein PPA-Repository hinzugefügt:
sudo add-apt-repository ppa:hrvojes/kde-goodies
sudo apt-get update

Das hat die Datei /etc/apt/sources.list.d/hrvojes-kde-goodies-oneiric.list erstellt,
mit diesem Inhalt:
deb http://ppa.launchpad.net/hrvojes/kde-goodies/ubuntu oneiric main
deb-src http://ppa.launchpad.net/hrvojes/kde-goodies/ubuntu oneiric main

Und installiert:
sudo apt-get install k4dirstat

Hat zwar funktioniert, aber k4dirstat lief nicht bis zum Ende durch.

Dann mit der Version von jeromerobert probiert, also:
sudo apt-get remove k4dirstat
sudo sed -i s/^/#/ /etc/apt/sources.list.d/hrvojes-kde-goodies-oneiric.list

sudo add-apt-repository ppa:jeromerobert/misc
sudo apt-get update
sudo apt-get install k4dirstat

Gleicher Fehler, aufgegeben.

Migration zu KMail2

Beim ersten Aufruf von KMail wird man zur Migration aufgefordert (sonst wird gedroht, ein
neues leeres Konto anzulegen).
Bei der Migration kam aber dieser Fehler:
In KMail ist ein schwerwiegender Fehler aufgetreten. Das Programm wird beendet.
Die Fehlermeldung lautet:
Fehler beim Einholen der Ressourcen-Sammlung.

Hier ist dieser Fehler bei der automatischen Migration beschrieben:
http://forum.ubuntuusers.de/topic/kmail2-fehler-beim-einholen-der-ressourcen-sam/#post-3471517
Der dort angegebene Link (https://wiki.ubuntu.com/OneiricOcelot/Final/Kubuntu/Kmail2) half weiter. Es war auch nicht so schlimm wie dort gesagt (Filter wurden doch migriert.)

Der KMail-Eintrag im Startmenü hat komischerweise nicht mehr funktioniert, hab’s dann immer von der Kommandoziele gestartet.

Außderdem funktionierte der Mailversand erst nach einem Neustart von Akonadi: http://forum.ubuntuusers.de/topic/kmail2-akonadi-e-mail-bleibt-in-der-outbox/

PXE-Server-Einrichtung

Bisher nur Teilerfolge, ohne abschließendenden Erfolg.

http://en.wikipedia.org/wiki/Preboot_Execution_Environment

Hauptsächlich nach dieser ANleitung
http://www.debian-administration.org/articles/478
http://ivanz.com/2007/01/31/opensuse-102-network-boot-and-installation-howto/
Modifiziert mit:
http://www.avrfreaks.net/index.php?name=PNphpBB2&file=viewtopic&p=794180

Ein wenig auch hier gelesen:
http://danhomolka.wordpress.com/how-tos-mainly-technical/setting-up-a-pxe-boot-environment-with-opensuse-linux/
http://aput.net/~jheiss/netboot_linux/
http://netboot.sourceforge.net/english/index.shtml
http://netboot.sourceforge.net/cgi-bin/getdoc.cgi?doc=HOWTO.html&lang=english&source=index&title=Netboot%20HOWTO

http://www.debian-administration.org/article/478/Setting_up_a_server_for_PXE_network_booting

Bisher ignoriert:
http://ubuntuforums.org/archive/index.php/t-1413126.html

Benutzerrechte für Netzwerk-Dateisystem

Ich hatte das Problem, dass alle meine neuen User „sunito“ heißen, ich aber noch einen Rechner habe, wo mein Nutzer anders heißt.
Das neue NFS (nfs4) ist deutlich sicherheitsbewusster, und setzt User mit den gleichen Ids nicht automatisch gleich, sondern überprüft auch die User-Namen.
Den „sound“ umzubenennen wollte ich nicht versuchen, da der alte User schon sehr lange existiert (und also der Name wahrscheinlich an vielen Stellen schon gespeichert ist).

Als Workaround, die Datei /etc/idmapd.conf bearbeitet,
und zwar im Abschnitt „[Mapping]“ den neuen Nutzer und die Gruppe „users“ eingetragen:

[Mapping]
Nobody-User = sunito
Nobody-Group = users

Dann den idmapd-Dienst neu gestartet
sudo service idmapd restart

Und das Netzlaufwerk neu gemaountet.

Workaround für Phonon-Bug, damit Skype funktioniert

In Natty gibt es ein Bug in Phonon, so dass sich die Priorität der Audio-Eingabegeräte (Mikrofone) nicht mehr verändern lässt.

Workaround entsprechend:
https://bugs.launchpad.net/ubuntu/+source/phonon/+bug/769274

Einfach das eingebaute Mikrofon über die Phonon-Lautsprechereinstellungen deaktiviert (als Profil nur Output gewählt), so wie es Yukka beschrieben hatte.

Plymouth repariert

Problem:
Beim Hochfahren erschien immer der Textbildschirm mit „mountall: Keine Verbindung zu Plymouth“
und dann hing das System ne lange Weile, fuhr dann aber normal hoch

Entsprechend:
http://paolobernardi.wordpress.com/2011/05/01/fix-plymouth-on-ubuntu-after-installing-nvidia-or-ati-proprietary-drivers-for-ubuntu-11-04-natty/
das Script heruntergeladen und ausgeführt:
wget http://www.webalice.it/bernardi82/software/fixplymouth-natty
chmod +x fixplymouth-natty
./fixplymouth-natty

(Mit dieser Auflösung: 1024×768-24)

k4dirstat installiert

Ab Ubuntu 11.04 Natty ist das gute alte KDirStat nicht mehr dabei.

Das neue k4dirstat ist aber noch nicht dabei.

Also, entsprechend der Anleitung in
http://grumpypenguin.org/index.php?/archives/3-KDirStat-coming-to-KDE4.html

Vorher aber erstmal die Development-Pakete installiert:

sudo apt-get install kdelibs5-dev
sudo apt-get install libkonq5-dev
sudo apt-get install cmake

Dann geht’s los:
git clone http://grumpypenguin.org/~josh/kdirstat.git

cd kdirstat
mkdir build
cd build
cmake ..
sudo make install

Dann Eintrag im Startmenü erzeugt, und zwar unter „Dienstprogramme“ mit dem Arbeitsverzeichnis „/“ (also Wurzel-Ordner) (auf dem Tab „Erweitert“).